Notices

© Agilent Technologies, Inc. 2005 - 2011

No part of this manual may be reproduced in any form or by any means (including electronic storage and retrieval or translation into a foreign language) without prior agreement and written consent from Agilent Technologies, Inc., as governed by United States and international copyright laws.

Manual Part Number
W4000-90045

Edition
Printed in Malaysia
Agilent Technologies, Inc.
5301 Stevens Creek Blvd.
Santa Clara, CA 95051 USA

Trademark Acknowledgements
Pentium is a U.S. registered trademark of Intel Corporation.
Microsoft, Visual Studio, Windows, and MS Windows are trademarks of Microsoft Corporation in the United States and or other countries.

Warranty
The material contained in this document is provided "as is," and is subject to changed, without notice, in future editions. Further, to the maximum extent permitted by the applicable law, Agilent disclaims all warranties, either express or implied, with regard to this manual and any information contained herein, including but not limited to the implied warranties of merchantability and fitness for a particular purpose. Agilent shall not be liable for errors or for incidental or consequential damages in connection with the furnishing, use, or performance of this document or of any information contained herein. Should Agilent and the user have a separate written agreement with warranty terms covering the material in this document that conflict with these terms, the warranty terms in the separate agreement shall control.

Technology Licenses
The hardware and or software described in this document are furnished under a license and may be used or copied only in accordance with the terms of such license.

Restricted Rights Legend
U.S. Government Restricted Rights. Software and technical data rights granted to the federal government include only those rights customarily provided to end user customers. Agilent provides this customary commercial license in Software and technical data pursuant to FAR 12.211 (Technical Data) and 12.212 (Computer Software) and, for the Department of Defense, DFARS 252.227-7015 (Technical Data - Commercial Items) and DFARS 227.7202-3 (Rights in Commercial Computer Software or Computer Software Documentation).

Safety Notices

CAUTION
A CAUTION notice denotes a hazard. It calls attention to an operating procedure, practice, or the like that, if not correctly performed or adhered to, could result in damage to the product or loss of important data. Do not proceed beyond a CAUTION notice until the indicated conditions are fully understood and met.

WARNING
A WARNING notice denotes a hazard. It calls attention to an operating procedure, practice, or the like that, if not correctly performed or adhered to, could result in personal injury or death. Do not proceed beyond a WARNING notice until the indicated conditions are fully understood and met.
Introduction

Welcome to the Agilent VEE family! Agilent Visual Engineering Environment (VEE) is a powerful visual language environment that dramatically reduces your development time. To get you started quickly on Agilent VEE, we have prepared this guide to show you how to install and use your new software. This guide also contains two tutorials that show you how to communicate with an instrument via the USB interface, and how to generate and display a waveform from a virtual source.

Installing Agilent IO Libraries

The Agilent IO Libraries Suite software is included when you purchase Agilent VEE. This software enables you to communicate with instruments via serial, USB, GPIB, or LAN interfaces.

You are required to install the Agilent IO Libraries Suite 16.1 before installing Agilent VEE if you need to communicate with instruments using Agilent VEE. However, you can choose not to install the Agilent IO Libraries Suite if you do not use instruments.

Follow these simple installation steps:

1. Insert *Agilent IO Libraries Suite CD* into the CD-ROM drive.
2. The InstallShield Wizard will guide you through the installation process. Click **Next** to accept the default settings and complete the installation.
3 The Agilent Connection Expert Welcome Screen window will appear. This application configures the instruments that are connected to your PC. You may close this window before proceeding to the next step.
 Installing Agilent VEE Pro

1 Insert the *Agilent VEE Installation CD-ROM* and click **Install Agilent VEE Pro 9.3**. The InstallShield Wizard will guide you through the installation process.

![Agilent VEE 9.3 Installation CD](image)

2 The InstallShield Wizard will check if Agilent IO Libraries Suite 16.1 is installed. If it is not, the following message box will appear.

![Agilent VEE Pro - InstallShield Wizard](image)

Please note that Agilent IO Libraries Suite 16.1 is a prerequisite if you communicate with instruments using Agilent VEE. So, please install Agilent IO Libraries Suite 16.1 or higher after finishing this installation.

3 Click **OK**, the InstallShield Wizard will check if Microsoft .NET Framework 3.5 SP1 is installed.

4 If Microsoft .NET Framework 3.5 SP1 is not installed, following Question dialog box will appear to ask you to install it. Click **Yes** to install the Microsoft .NET Framework 3.5 SP1 immediately. After the installation, the Agilent VEE installation will continue automatically. Clicking **No** will abort the Agilent VEE installation.
If Microsoft .NET Framework 3.5 SP1 is installed, the InstallShield Wizard will guide you to the next step directly to install your Agilent VEE selection in Step 1.

5 Click **Next**, when the following dialog box appears.

6 Accept the license agreement when the License Agreement dialog box appears, then click **Next**.
7 Type your name, company name, and product key when the Customer Information dialog box appears, then click **Next**. The product key is contained in the *Agilent VEE Pro Product Key Certificate*.

8 Click **Next** to accept the default settings when the following dialog box appears.
9 Select **Typical Setup** when the Setup Type dialog box appears, then click **Next** to complete the installation.
Launching Agilent VEE Pro

Go to All Programs > Agilent VEE Pro 9.3 > VEE Pro 9.3 to launch Agilent VEE Pro.

You can access the demos, MATLAB examples as well as sample programs via the Agilent VEE Pro welcome window. You may close the window after exploring it.

You can also open sample programs from the menu bar. To open a sample program, go to File > Open Example ...or Help > Open Example....
Instrument Communication Tutorial

In this tutorial, we will connect to an instrument via the USB interface. Ensure that the Agilent IO Libraries Suite 16.1 is installed before proceeding.

If you do not have a USB instrument, the tutorial for a GPIB instrument is similar from Step 3 onwards.

1. Connect to an instrument via any USB port on your PC. Then, turn on the instrument. The Found New Hardware Wizard dialog box will appear. Just step through the wizard by clicking **Next**.

2. Launch Agilent VEE Pro, if you have not. Click the **Instrument Manager** button on the toolbar.

3. The Instrument Manager tool window will appear. Click the **Find Instruments** button to automatically detect all instruments connected to your PC.

4. Click **Yes** if the Identify Instrument pop-up dialog box appears. This automatically identifies the instrument on the USB interface. In this example, the Agilent 34410A Digital Multimeter is present.
5 Right click newInstrument in the Instrument List panel. Then, choose **Create Direct I/O Object** to place a Direct I/O object for the selected new instrument on the workspace. This object allows you to send/receive commands to/from your instrument.

6 Double-click the Direct I/O object blue transaction bar to add a transaction to the Direct I/O object.

7 Type "*IDN?" (include the quotation marks) in the I/O Transaction dialog box as shown below. A list of available SCPI commands may appear while you are typing. You can choose one command as desired instead of typing the whole command. Click **OK** to proceed.

*IDN? is one of standard commands for programmable instruments (SCPI) command that queries the instrument for its identification string.
8 After sending the "*IDN?" query to the instrument, you need to read back its response. Double-click the text box of the new Instrument object to add a new transaction. This time, select the transaction to READ a STRING FORMAT text to an output terminal named x. The output terminal x will be automatically created when you click OK.

9 Select Display > AlphaNumeric and place an AlphaNumeric object on the workspace to the right of the Direct I/O object.

10 You will now connect the Direct I/O object to the AlphaNumeric object. Place the mouse cursor beside the Direct I/O output terminal and a square icon will appear. Left-click and drag a line to the input terminal of the AlphaNumeric object. Left-click again to complete the connection.
11 Run the program by clicking the Run button on the toolbar.

12 The AlphaNumeric object will display the identification string output by the instrument as shown below.

13 To save your VEE code, select File > Save As and name the file as Tutorial 1.vee.
Virtual Source Tutorial

In this tutorial, you will generate and display a waveform from a virtual source. No instrument is needed.

1. If you have an existing program in your Agilent VEE Pro workspace, select File > New. Then, select Device > Virtual Source > Function Generator and place a function generator object on the workspace.

2. By default, the function generator will generate a virtual cosine waveform at a frequency of 200 Hz, and an amplitude of 1.
3 Select **Display > XY Trace** and place an XY Trace object to the right of the function generator.

4 Connect the function generator output terminal to the input terminal of the XY trace. Place the mouse cursor beside the function generator output terminal and a square icon will appear. Left-click and drag a line to the input terminal of the XY Trace object. Left-click again to complete the connection.

5 Click the **Run** button on the toolbar and you can see the cosine waveform displayed on the XY Trace object.
6 Select **Display > Spectrum (Freq) > Magnitude Spectrum** and place a Magnitude Spectrum object on the workspace below the **XY Trace object**.

7 Connect a second line from the output of the function generator to the input of the Magnitude Spectrum object using the same left-click and drag method as described in Step 4.

8 Click the **Run** button and observe the magnitude spectrum display. As the waveform is a 200 Hz cosine, the magnitude spectrum displayed will be a vertical line at the frequency of 200 Hz.
9 Change the waveform function on the virtual function generator to a square waveform.
10 Click the Run button and observe the difference. Agilent VEE gives you the flexibility to analyze your signal source in multiple graph displays simultaneously.

11 To save your VEE code, select File > Save As and name the file as Tutorial 2.vee.
Agilent VEE 9.3 New Features

vTools

There are two available vTools, General vTools and DAQ vTools. General vTools contains enhanced graph object with panning, scroll zoom, graphic saving features, and printing capabilities to improve the graph object reporting feature. General vTools also supports objects and components such as Averaging and Marker Lookup. DAQ vTools offers better integration and supporting files generated from Agilent Measurement Manager for DAQ modules. The DAQ vTools is only available for Agilent U2300 and U2500 Series USB modular data acquisition.

New Sample Programs

There are new sample programs for Agilent 33500 series, 34411A DMM, and DSO/MSO scopes. These new sample programs will demonstrate on simple programming for new Agilent instruments with VEE. For more information on the new sample programs, refer to the VEE 9.3 Help File.

NOTE

Agilent also provides Agilent VEE Student and Agilent Education versions for academic users.
Agilent Connectivity Products

E5810A LAN/GPIB Gateway
82357B USB/GPIB Interface
10833X GPIB Cable
82350B PCI GPIB Interface
82351A PCIe GPIB Interface

Agilent provides a complete range of high performance and highly reliable products to connect from your PC to your instruments. These include LAN/GPIB gateway, GPIB cable PCI GPIB, PCIe GPIB, and USB/GPIB interfaces. For more information on Agilent connectivity products, visit www.agilent.com/find/gpib.
Agilent Support, Services, and Assistance

With Agilent VEE Pro, you have access to the Agilent worldwide resources for start-up assistance, training classes, and update services. As part of the purchase of any Agilent VEE product you are entitled to receive technical support free of charge. There is no need to register.

Additional consulting services are available from Agilent. There are currently over 30 companies available in North America, Europe, Middle East and Asia to help you develop your Agilent VEE solution.

Sign up for the Agilent VEE forum at http://www.agilent.com/find/veeforum, and get help on using Agilent VEE from experts around the world.

Sign up for Agilent VEE e-learning courses (LearnVEE) at http://www.agilent.com/find/learnvee.

For an interactive help, you may also view Agilent VEE multimedia demos at http://www.agilent.com/find/veedemos.
Appendix

Agilent VEE Pro Help is now available in other languages. To use online help file in other languages, please

1 Download localized online help from www.agilent.com/find/vee.

2 Save downloaded files into the installation directory of Agilent VEE. Generally, it is C:\Program Files\Agilent\VEE Pro 9.3. Please do not change the name of the downloaded online help files.

3 Open Agilent VEE software.

4 Open the Default Preferences (File => Default Preferences). Choose the help file language as you need under the Help tab.

5 Click OK to close the Default Preferences dialog box.
Contact us

To obtain service, warranty or technical support assistance, contact us at the following phone numbers:

United States:
(tel) 800 829 4444 (fax) 800 829 4433
Canada:
(tel) 877 894 4414 (fax) 800 746 4866
China:
(tel) 800 810 0189 (fax) 800 820 2816
Europe:
(tel) 31 20 547 2111
Japan:
(tel) (81) 426 56 7832 (fax) (81) 426 56 7840
Korea:
(tel) (080) 769 0800 (fax) (080) 769 0900
Latin America:
(tel) (305) 269 7500
Taiwan:
(tel) 0800 047 866 (fax) 0800 286 331
Other Asia Pacific Countries:
(tel) (65) 6375 8100 (fax) (65) 6755 0042

Or visit Agilent worldwide web at:
www.agilent.com/find/assist

Product specifications and descriptions in this document are subject to change without notice. Always refer to Agilent Web site for the latest revision.

© Agilent Technologies, Inc. 2005 - 2011

Printed in Malaysia

W4000-90045